Ascent Network Version Can't Receive vb Data

PROBLEM

When transferring data from the instrument to my Ascent network version this error message appears:

Database_update_conflict_error

CAUSE

This message can appear when the Ascent program is having locking issues on the database. This normally occurs when more than one process is trying to change the same information in the database; see solution 1.

It can also be caused by the program not closing down properly, thereby locking the database; see solution 2.

SOLUTION

  1. If there are other users logged into the Ascent program (assuming you are using Ascent network version) you will need to wait till the other user has saved their changes. When they have done this a Refresh button will appear on your toolbar. Click Refresh then try transferring the data again.
  2. If the program has not shut down properly it may not have relinquished its hold on the database. In this case you will need to re-start the InterBase Server that the Ascent database is located on. (Although you may have the Ascent program installed on your personal computer the actual database may be located on a central server so that everyone across your network has access to it. In this case you will need to ask your IT department to re-start InterBase on their server for you.)

 

  • Start the InterBase Manager from the Windows Control Panel. For Windows XP you can find this under Start>Settings>Control Panel. Double-click the InterBase Manager to start the program.

InterBase_server

  • Click Stop. The Stop button will change to a Start button indicating that InterBase is no longer running.
  • Click Start to re-start InterBase. This should clear the database locks and allow you to receive data from the vb instrument again.

FAQ ID: 14001 Last Reviewed: 26 September 2005

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