Problems with InterBase Indexes (Ascent 7.30 only)

SYMPTOMS

Slow database access, 'Multiple Rows in Singleton Fetch' errors, 'Check keylinks/joinlinks' errors.

CAUSE

Database indexes are inactive; this slows down database queries and also allows records with duplicate primary keys to be created. There is a problem with the File>Restore command as it does not guarantee that indexes will be active when the operation is complete.

SOLUTION

This issue only occurs in Ascent version 7.30. The easiest fix is to upgrade to the latest Ascent software from our website download area. If you still wish to use Ascent 7.30 follow these instructions:

Follow the procedure below to restore from a backup file using the Open>Change>Create commands - do not use File>Restore.

  • Start the software.
  • Make sure that you have a backup file of your database using File>Backup now! if necessary.
  • Select File>Open.
  • Click Change at the top-right of this window.
  • Choose to create a new database then click OK.
  • Click Save to replace your existing database file.
  • Answer Yes to the prompt 'A database file already exists with that name. Overwrite?'.
  • The program will ask you if you want to restore from your most recent backup file. If it has located the right file, click Yes. If it didn't identify the file with the right date/time click No and locate it manually.
  • Wait for the processing to complete. If you get any error messages such as:

'ISC ERROR MESSAGE: violation of PRIMARY or UNIQUE KEY constraint...'

click Yes to ignore it. If you have a lot of duplicate records in your database you may need to click Yes many times (a Yes to all button is in the works). Press the keyboard Y key as a shortcut to answer the Yes question (if you use the Space bar you may accidentally select the Cancel button in the progress window).

  • If you did encounter any of the problems in the previous step make a new backup copy using File>Backup now! This new backup copy will not have any of the duplicate records.

Now review your database and check that:

  • all your data is there
  • you don't get any more error messages
  • the database is performing faster

You now have an indexed database file and a good backup file too.

FAQ ID: 11633 Last Reviewed: 21 September 2005

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